[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: getting past anonymous bind


Here is my configure for openldap on RH7.3.

 ./configure  --prefix=/var/ldap --mandir=/usr/share/man

Very simple build.  The SASL and SSL inclusions are defaults in the 
config as I remember.

I don't think your problem is really in the config 
of the server.  Try doing an ldapsearch, the syntax is in the openldap 
documentation found here: http://www.openldap.org/doc/
Look at the quick start section for ldapsearch.

Have you edited slapd.conf?  What access controls do you have?  You may 
not be allowing users to connect for read.  I am still working out my 
access controls also, but I can read as a user.  Start with "access to * 
by *" then tighten from there.

On Wed, 19 Jun 2002, ifconfig - wrote:

> hi there,
> I'm still trying to solve the issue of connecting as a user instead of 
> anonymously form ldap browser, but still cannot error. I have tried to 
> compile sasl and openssl with the following configure command
> env CPPFLAGS="-I/usr/include/sasl" LDFLAGS="-L/usr/lib -L/usr/lib/sasl" 
> ./configure --enable-login --disable-krb4 --disable-gssapi 
> --with-des=/usr/include/openssl --without-kerberos --disable-kpasswd 
> --with-cyrus-sasl-includes=/usr/include/sasl 
> --with-cyrus-sasl-libraries=/usr/lib/sasl/ --enable-spasswd
> Does look right to anyone.
> I start ldap after install, but still no luck. Are there any steps i am 
> missing. Any help much appreciated.
> Thanks.
> _________________________________________________________________
> Join the world?s largest e-mail service with MSN Hotmail. 
> http://www.hotmail.com

Andrew Bacchi
Staff Systems Programmer
Rensselaer Polytechnic Institute
phone: 518 276-6415  fax: 518 276-2809