[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Test fails; invalid credentials (was: BerkeleyDB 4 OK?)

OK, this was my fault. I'll post the reason here in case anyone else runs into it:

The test routines rely on the use of cleartext passwords. I had specified the --disable-cleartext option to the configure script, so any test that was attempting to bind with the cleartext password "secret" was failing.

I rebuilt without that option and all the tests succeeded.


On Tuesday, January 22, 2002, at 05:34 PM, Allan Streib wrote:

I went ahead and built OpenLDAP 2.0.21 against BerkeleyDB 3.2.9, and the segmentation fault in the test went away. So it appears related to that.

Now, I get to test002 and it fails trying to bind as the manager DN (cn=Manager, o=University of Michigan, c=US). The message in tests/test-db/test.out is "ldap_bind: Invalid credentials"

Is this a bug in the 2.0.21 test routines or something else? I'll keep playing with it, but I'm hoping someone else has run into this already.



On Tuesday, January 22, 2002, at 03:13 PM, Allan Streib wrote:

I am trying to build OpenLDAP 2.0.21 with BerkeleyDB 4.0.14, and am getting segfaults in the "make test" step (RedHat 7.2 system). I read earlier emails that 3.2.9 was the supported BerkeleyDB, but that was in relation to OpenLDAP 2.0.11. I saw mention of BerkeleyDB 4 compatibility in the CHANGES file, so I thought it might work.

Should I go back to BerkeleyDB 3.2.9 or is my problem likely something else?



Allan M. Streib
IT Policy Office - OVPIT                       | astreib@indiana.edu
Indiana University                             | voice: (812) 855-9860
http://php.indiana.edu/~astreib/my.pgp.key     | fax: (812) 855-7868