[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: OpenLDAP, PHP and OS X

you have also to configure /etc/httpd/conf/httpd.conf
in the line beginning with directoryindex add the proper index file (me it's index.php3)
add two lines like:
AddType application/x-httpd-php3 .php3 .phtml .php
AddType application/x-httpd-php3-source .php3
and (as I use mod-php3) add a line like:
include conf/addon-modules/mod-php3.conf

my mod-php3.conf contains:
LoadModule php3-module   /usr/lib/apache/libphp3.so
AddModule mod-php3.c

but I think you will find on the net how to configure apache to work with php4

hope that will help you
best regards,

At 22:11 15/01/02 -0700, Quinn Perkins wrote:
My Apache server will not even start. I can't run a PHP page.


On Tuesday, January 15, 2002, at 04:40  PM, Edwin Culp wrote:

Have you tried a php page with the following
When you access it with your browser it will display more than you want to
know about your installation but there should be a section about ldap.
Mine fillows:


LDAP Support         enabled
RCS Version          $Id: ldap.c,v 1.114 2002/01/04 20:56:03 venaas Exp $
Total Links          0/unlimited
API Version          2004
Vendor Name          OpenLDAP
Vendor Version       20019

This also reminds me to upgrade :-)

Good luck,


Quoting Quinn Perkins <quinn@quinnperkins.com>:

The frustrating part is, I had this working on OS X 10.0.4. I am now
running 10.1.2 Server.

I successfully built OpenLDAP and it is working fine.

I successfully built a version of PHP 4.0.6 for OS 10.1 with the
instructions found at
http://developer.apple.com/internet/macosx/php.html. It compiled without
error using:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
--mandir=/usr/share/man --with-apxs --with-zlib --with-
ldap=/Users/quinn/Desktop/Services/ldap/ldap --disable-pear

After moving the libphp4.so and editing the httpd.conf file, I started
the web server, but got the following error:

dyld: /usr/sbin/httpd Undefined symbols:
/usr/sbin/apachectl start: httpd could not be started

Now...my OpenLDAP works fine. My PHP with LDAP compiled without error.
Anyone have any ideas as to what might be wrong?

- Quinn