[Date Prev][Date Next] [Chronological] [Thread] [Top]

Connection Stability Troubles with LDAP

We are running OpenLDAP 2.0.7 on Windows 2000 with a Berkley DB (ldbm)

The problem we are having is that connections fail for an unknown reason.
The service is still running, but connections to the LDAP service are
rejected with "ldap_bind: Can't contact LDAP server".  It is not a
configuration problem because we performed successful ldapsearch commands
just prior to the problem occurring.  The same ldapsearch command failed
when the problem occurred.  After I stopped/restarted the openldap service,
the ldapsearch worked again.  Stopping the service took a long time - 1 or 2
minutes.  It normally takes seconds.  Also, if we leave it alone (i.e. don't
stop/restart the service) connections to LDAP are successful again after a
short period of time.

I tried running a load test with several clients sending endless ldapsearch
commands, but LDAP responded to each client without a hiccup.  We are
thinking that it is a combination of requests within our code that is
causing the problem, but can't track it down yet.  We do not perform any
modifies within the code.  The code that is running when the connections are
lost only performs searches.  The only updates we do are in a completely
separate application that is not running at the time of our problems.

Are there any known connection stability issues with the version of openldap
we are using or the platform on which we are running?  Does anyone have any
insight into the problems we are encountering?

Thanks for any help you may have.

Shane C. Marshall
Database Administrator
Softricity, Inc.
332 Congress Street
Boston, MA 02210
ph 617.695.0336 x169
fx 617.338.7769
www.softricity.com - Powering Software as a Service