[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Configure failed.

It appears that you have /usr/ucb in your path before the directory where
gcc is installed.  You need to remove /usr/ucb from the path.

You also need to fetch 2.0.11 becuase 2.0.10 will not run on Solaris.


On Thu, 24 May 2001, Hao, Weixing wrote:

> Hello,
> Configureation is failed during installing most recent version 2.0.10 on
> Solaris 8, configing output like:
> Copyright 1998-2001 The OpenLDAP Foundation,  All Rights Reserved.
> Restrictions apply, see COPYRIGHT and LICENSE files.
> Configuring OpenLDAP 2.0.10-Release ...
> checking host system type... sparc-sun-solaris2.8
> checking target system type... sparc-sun-solaris2.8
> checking build system type... sparc-sun-solaris2.8
> checking for a BSD compatible install... build/install-sh -c
> checking whether build environment is sane... yes
> checking for mawk... no
> checking for gawk... no
> checking for nawk... nawk
> checking whether make sets ${MAKE}... yes
> checking for working aclocal... found
> checking for working autoconf... found
> checking for working automake... found
> checking for working autoheader... found
> checking for working makeinfo... missing
> checking for gnutar... no
> checking for gtar... no
> checking for tar... tar
> checking configure arguments... done
> checking for cc... cc
> checking for ranlib... :
> checking for gcc... (cached) cc
> checking whether the C compiler (cc   ) works... no
> configure: error: installation or configuration problem: C compiler cannot
> create executables.
> I just have a new Solaris 8 system installed and I believe that the computer
> is also brand new Sun utltra 10, and gcc 2.95.3 is only compiler on the
> machine. Configure log file is also attached.
> Could someone point me where the problem is?
> Thanks.
>  <<config.log>>