[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Trouble running configure

Try Sleepycat db 2.7.7.  It's looking for a version 2, not 3.

"Cornwall, George" wrote:

> We are currently having a problem installing OpenLDAP 1.2.11 on a Solaris
> 2.7 system. We are using gcc and have installed Berkeley 3.2 as our LDBM.
> When executing the configure script we get the error message:
> checking for DB2 library... checking for db_open in -ldb... no
> no
> checking for db.h... yes
> checking if db.h is DB2... no
> checking for Berkeley DB2... no
> configure: warning: could not find suitable LDBM backend
> configure: error: select appropriate LDBM options or disable
> I have noticed this similar posting numerous times and   the solution was to
> always set the CPPFLAGS and LDFLAGS accordingly:
> env CPPFLAGS="-I/usr/local/BerkeleyDB.3.2/include"
> LDFLAGS="-L/usr/local/BerkeleyDB.3.2/lib" ./configure --with-ldbm-api=db2
> Unfortunately this has not resolved our problem. Reading the log file
> doesn't seem to shed any further light on this issue.
> Any help will be greatly appreciated.
> Thank you.
> Ged Cornwall
> Senior Architect, Web Solutions
> gcornwall@citistreetonline.com
> 904.791.2195