[Date Prev][Date Next] [Chronological] [Thread] [Top]

OpenLDAP 1.2.11 - Solaris 2.6 - pthread issues

It seems like we are having some issues with our testing of OpenLDAP
1.2.11... Here's the deal:

Run on Solaris 2.6 (Latest patches for all pthread related stuff... Infact,
pretty much the latest patches for everything).
OpenLDAP 1.2.11

Testing: We are using qmail, and authenticating through ldap (For POP,IMAP
and SMTP connections).
50 Connections/sec - Random lookups on indexed fields directly
40 Connections/sec - Random POP connections (From a list of known users)
10 Connections/sec - Random IMAP connectoins (From a list of known users)
10 Udaptes (1 addition, 3 modifications and 1 deletion)/min - Random

Basically, we are hitting a wall after about 5 hours or so of this... It
starts reporting "Jan  3 09:07:15 crypt slapd[27828]: ldap_pvt_thread_create
failed (1)" and stops returning searches (Actually, I think all it does is
accept the connection, then hang). I've searched the archives for the list
and it looks like this is an issue with Solaris' implementation of pthreads
(Compiled using:

env ac_cv_func_pthread_create=no ol_cv_kthread_flag=no ol_cv_pthread_flag=no
ol_cv_pthreads_flag=no ol_cv_thread_flag=no
LDFLAGS=-L/usr/local/BerkeleyDB/lib CPPFLAGS=-/usr/local/BerkeleyDB/include
./configure --prefix=/usr/local/openldap-1.x --enable-ldbm

As laid out in the FAQ), but I'm wondering if there is a work around (Other
then compiling with --without-threads).


Laurence Brockman
Unix Administrator
Videon Cablesystems Alberta Inc
10450-178 St.
Edmonton, AB
T5S 1S2
(780) 486-6527