[Date Prev][Date Next] [Chronological] [Thread] [Top]

ldif2ldbm question

Hi there. Sorry is this is a FAQ, but I've switched from version 1.2.11
(20000704) of OpenLDAP to version 2.0.1
I am trying to import a generated ldif file into the Berkley DB backend
(Version  2.7.7) using the ldif2ldbm command...
Here's what it looking like:
# /usr/local/sbin/ldif2ldbm -i /home/laurence/Patches/surfr091300.ldif -f
/usr/local/etc/openldap/slapd.conf -s /usr/local/sbin
/usr/local/etc/openldap/schema/core.schema: line 114: expecting "requires"
or "allows" got ""
<oc clause> ::= objectclass <ocname>
                [ requires <attrlist> ]
                [ allows <attrlist> ]

Now, I assume that it is expecting the old syntax (Without the OID's). But I
am using the new schema and I'm wondering if there is any way around this?

Again, sorry if this is a faq, but I've search the mail lists, the FAQ, the
docs, even on google.com and I'm stumped... I'm assuming that all I need is
a new version of ldif2ldbm or some other import utility.

Thanks in advance,

Laurence Brockman
Unix Administrator
Videon Cablesystems Alberta Inc
10450-178 St.
Edmonton, AB
T5S 1S2
(780) 486-6527