[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: commit: ldap/servers/slapd Makefile.in

masarati@aero.polimi.it wrote:
masarati@aero.polimi.it wrote:
Update of /repo/OpenLDAP/pkg/ldap/servers/slapd

Modified Files:
	Makefile.in  1.198 ->   1.199

Log Message:
ITS#3272 link against libslapi.la

Seems to have broken build with --enable-slapi.

Working fine here. What's your configure invocation? Mine is this:

./config.status --recheck
running CONFIG_SHELL=/bin/sh /bin/sh ../head/configure --enable-modules
--enable-ldap --enable-meta --enable-overlays=mod --enable-perl
--no-create --no-recursion

configure \
         --enable-modules \
         --enable-dynamic=no \
         --enable-dynacl \
         --enable-aci \
         --enable-slapi=yes \
         --enable-backends=yes \
         --enable-overlays=yes \
         --enable-ndb=no \

The error is

make[2]: *** No rule to make target `libslapi.a', needed by `slapd'.  Stop.
make[2]: Leaving directory
make[1]: *** [all-common] Error 1
make[1]: Leaving directory
make: *** [all-common] Error 1

In fact, now there's only a rule for libslapi.la.

Indeed so where did the libslapi.a dependency come from?

violino:~/OD/head/servers/slapd> grep libslapi.a Makefile.in

violino:~/OD/hobj/servers/slapd> grep libslapi.a Makefile

  -- Howard Chu
  CTO, Symas Corp.           http://www.symas.com
  Director, Highland Sun     http://highlandsun.com/hyc/
  Chief Architect, OpenLDAP  http://www.openldap.org/project/