[Date Prev][Date Next] [Chronological] [Thread] [Top]

`LDAP_PROXY_AUTHZ_FAILURE' undeclared here


I'm trying to build a local installation of the OpenLDAP 2.1.16 libs without SASL support.

export CFLAGS="-O2 -I$HOME/local/include"
export LDFLAGS="-L$HOME/local/lib"
export LD_LIBRARY_PATH="$HOME/local/lib"

./configure \
  --prefix=$HOME/local \
  --with-threads \
  --without-cyrus-sasl \
  --without-kerberos \
  --with-tls \
  --disable-static \
  --disable-slapd \

But the build fails with the following error message:

/bin/sh /tmp/openldap-2.1.16/libtool --mode=compile cc -O2 -I/user/W3311/local/include -I../../include -I../../include -O2 -I/user/W3311/local/include -DLDAP_LIBRARY -c error.c
cc -O2 -I/user/W3311/local/include -I../../include -I../../include -O2 -I/user/W3311/local/include -DLDAP_LIBRARY -c error.c -fPIC -DPIC -o error.lo
error.c:56: `LDAP_PROXY_AUTHZ_FAILURE' undeclared here (not in a function)
error.c:56: initializer element for `ldap_builtin_errlist[26].e_code' is not constant
make[2]: *** [error.lo] Error 1
make[2]: Leaving directory `/tmp/openldap-2.1.16/libraries/libldap'
make[1]: *** [all-common] Error 1
make[1]: Leaving directory `/tmp/openldap-2.1.16/libraries'
make: *** [all-common] Error 1

Any clue?

Ciao, Michael.