[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: HEADS UP: back-bdb now requires BDB 4.1

>>>>> "Kurt" == Kurt D Zeilenga <Kurt@OpenLDAP.org> writes:

> Because few folks actually read release READMEs (which says BDB 4.1 is
> required), configure now enforces the requirement...

Including me :-(. We had some pretty bad data corruption issues with
OpenLDAP 2.1. I don't know if it was related to using BDB 4.0.14; we have
temporarily reverted OpenLDAP 2.0 :-). One reason many people seem to go
with BDB 4.0 is the ready availability of the RPM on recent Redhat

Surprisingly there seems to be no official RPM for 4.1.25; I built one
myself based on a version for the Polish Linux Distro. I am currently
testing 2.1.12 with OpenLDAP 2.1.25.

I know the OpenLDAP project does not host binary RPMS, but if any one is
interested in BDB 4.1.25 RPMs, I can upload it to some public site. 


Ganesan R