[Date Prev][Date Next] [Chronological] [Thread] [Top]

LDAPv2 -> LDAPv3 in slapd and client API


in the devel version the slapd refuses LDAPv2 binds (if not configured 
differently in slapd.conf). At the same time the default value for the 
protocol version is set to LDAP_VERSION2 in ldap_init (actually in 
ldap_int_initialize_global_options). Is there a reason for this behaviour? 
Shouldn't the default better be set to LDAP_VERSION3? 

I know that I can set the protocol version from my application program, but I 
would guess that might lead to problems with third party applications which 
just use the OpenLDAP-API and don't care about protocol versions.

Stephan Siano

Stephan Siano                           Mail:  Stephan.Siano@suse.de
SuSE Linux Solutions AG                 Phone: 06196 50951 31
Mergenthalerallee 45-47			Fax:   06196 409607
D-65760 Eschborn