[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: Returning wrong entry for a dn

> I suggest you redirect this enquiry over to our software list.
> 	Kurt
I already directed it to software list. I haven't heard back from any one.

> (sounds like you should rebuild your indices)
I didn't build any indices when I installed them.

> At 11:11 AM 2/7/00 -0600, Nalla, Suneetha R (Suneetha) *CTR* wrote:
> >Hi,
> >
> >I am having a strange problem with my openldap slapd server. 
> I actually have
> >a slapd running on solaris 2.6 supporting two different 
> suffixes on the same
> >server. I am trying to do a search for an entry from the 
> database and I am
> >getting the wrong entry for it. 
> >
> >I have two suffixes "o=comp1,c=US" and "o=comp2,c=US" 
> supported on the same
> >server. I have a bunch of entries under each. When I am 
> trying to do a
> >search on an entry under "o=comp1,c=US" the result I am 
> getting is the base
> >object in the second suffix i.e. object "o=comp2,c=US". I 
> have entries from
> >1000 to 1009, 1000 entry is good I am getting the right ones 
> back. But 1001
> >is the entry that's giving problem.
> >When I do a search on this with "dn:
> >edigit=1,edigit=0,edigit=0,edigit=1,o=comp1,c=US" I get back:
> >dn: o=comp2,c=US
> >objectclass: top
> >objectclass: organization
> >o: comp2
> >When I try to delete that entry, I get back: Operation not allowed on
> >nonleaf. When I created this entry this is the leaf object 
> and now I don't
> >know why it's saying that and why it's giving the wrong 
> result for search.
> >
> >When I do a search on the next number 1002 with "dn:
> >edigit=2,edigit=0,edigit=0,edigit=1,o=comp1,c=US" I get 
> back: No such object
> >When I try to delete that entry it gives: No such object
> >When I try to add it again it gives: Already exists
> >It does the same thing for the entry 1003 also. But again 
> the entries after
> >that are fine 1004, 1005 ......1009 are all returning the 
> right ones back. 
> >
> >I am having problem deleting entries from under the second 
> suffix. Adding,
> >modifying, searching is all fine but I am having problem deleting the
> >entries under second suffix it says "Operation not allowed 
> on nonleaf" when
> >I know that is a leaf object. If I do a search on the 
> entries with sub
> >option I don't get any thing else under that object and when 
> I created them
> >I created as the leaf objects.
> >
> >I actually imported some of the entries under the first suffix
> >"o=comp1,c=US" from an old server supporting only this 
> suffix. All the
> >entries under the second suffix "o=comp2,c=US" were created new after
> >creating a new server supporting both suffixes.
> >
> >I ran the server in debug mode but could not figure out 
> anything. I can send
> >the out put from the server in debug mode if you need to 
> look at it. Did
> >somebody encounter this problem before. It will be great if 
> somebody could
> >help me with this.
> >
> >Thanks, for the help.
> >Suneetha.
> >
> >Suneetha R. Nalla
> >nalla@lucent.com
> >
> >