[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#7260) problem with 2.4.30 to 2.4.31 upgrade

> Full_Name: Andrzej Tobola
> Version: 2.4.31
> OS: FreeBSD 9.0 amd64
> URL: ftp://ftp.openldap.org/incoming/
> Submission from: (NULL) (
> I run slapd  from a long time on FreeBSD stable amd64 and it is started
> with
> args:
>   slapd -4 -h "ldapi://%2fvar%2frun%2fslapd.socket ldap://localhost/
> ldap://ldap2/ ldaps://ldap2/"  -u ldap -g ldap
> After upgrade from 2.4.30 to 2.4.31 my server can't start:
> slapd[29221]: read_config: no serverID / URL match found. Check slapd -h
> arguments.
> Nothing was change in en environment - only ldap was upgraded.
> After backing-off only this one commit to bconfg.c:
>   http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commitdiff;h=b4d403ea310022ca4ffcbf31fa20ead6c754f28d
> all is working again.
> Any clue ?
> and IHMO this message shod be more informative for casual user.

This message (and the related commit) adds a sanity check (ITS#7200). 
Apparently, your system is (and was) misconfigured.  So I'd try to
understand what the misconfiguration is, rather than backing up to a
version without sanity check.

This discussion belongs to openldap-technical@openldap.org rather than to
the ITS. You showed the value of -h, can you show your serverID /