[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#7054) Please drop support to FreeBSD 1.x

Given the project doesn't specifically attempt to support FreeBSD 1.x, your request as summarized in the subject line is a bit odd.

I suggest this be considered more of a request to enable future support of the FreeBSD 10.x.

Do the current release of libtool and autotools includes the enabling features needed?

If so, then this can simply be treated as a request to update these tools (which are generally incorporated without any functional change).

If not, well, then we should just wait for thsoe enabling changes to be released by the upstream tool provider first?

Regards, Kurt

On Sep 28, 2011, at 2:38 PM, delphij@FreeBSD.org wrote:

> Full_Name: Xin Li
> Version: git trunk
> OS: FreeBSD/amd64 10.1
> URL: http://pastebin.com/G8gpJs0r
> Submission from: (NULL) (
> Code duplicated from GNU libtool and autotools uses 'freebsd1*' rather than
> 'freebsd1.*' to test if the system is FreeBSD 1.x.  This logic would match
> FreeBSD 10.0, causing problem when building shared libraries.
> I'd like to propose that FreeBSD 1.x support be dropped since it's obsolete in
> 1994 (17 years ago).
> The patch is just for reference, it also drops FreeBSD 2.x and FreeBSD 3.x
> support but it's not complete.
> A libtool patched with git revision e94c6d6e0359d92f08f491f57e0ef3371e978952
> would also be required to build OpenLDAP properly.