[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#6984) Enable draft-wahl-ldap-session in RE24

> Full_Name: Michael Ströder
> Version: 2.4.x
> OS:
> URL:
> Submission from: (NULL) (
> It seems there is support for draft-wahl-ldap-session in OpenLDAP's source
> since
> 2007 but it seems not to be enabled in a default build. It's hidden behind
> ifdef-statements and one has to use -DLDAP_DEVEL when compiling which is
> not
> supposed to work with RE24.
> I've tested it with HEAD and I'd be glad this could be enabled for
> standard
> builds in 2.4 series.

As far as I understand, support is complete and conforms to draft as of
the time it was implemented.  Since the draft expired, it has never been
released.  Moreover, I sent the author some comments about how the draft
could be improved, IMHO, but received no answer (I don't recall whether
the discussion was in ldapext or personal, though).  If it can be useful,
I surely favour its release, provided this complies with the project's
policy towards support for expired drafts.