[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#6537) arl[authority revocation list] issue during opneldap upgrade

> Full_Name: Mayashankar Mishra
> Version: 2.4.21
> OS: rhel5
> URL: ftp://ftp.openldap.org/incoming/
> Submission from: (NULL) (
> Hi,
> I have to upgrade the openldap from version 2.2.26 to 2.4.21
> All goes fine except for the arl[authority revocation list] failed to get
> added
> in new database.
> I see the binary version of arl from old openldap, its fine.
> When i try to upload the same on openldap 2.4.21 it provides the error
> Root error: [LDAP: error code 21 - authorityRevocationList;binary: value
> #0
> invalid per syntax]
> Note the same arl when added in older version of openldap works fine
> Any guess what could be the reason

This is not a bug, but likely invalid data.  Certificate list syntax
validator and all related routines were stubs until 2.4, so basically
everything was treated as valid.  Now the syntax is validated thoroughly. 
This ITS will be closed.  Please continue discussion on openldap-software,
if needed.  Only in case a valid certificate list is not correctly
validated (i.e. you detect an actual bug in that code), this ITS can be