[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#6535) OpenLDAP fails to build with back-ndb enabled

giesen@snickers.org wrote:
> Full_Name: Gary T. Giesen
> Version: 2.4.21
> OS: RHEL 6 Beta 1
> URL:
> Submission from: (NULL) (
> OpenLDAP 2.4.21 (as well as 2.4.19) fails to configure or build on RHEL6 with
> back-ndb support enabled. I've solved the problem with configure by applying a
> modified version of the patch found here:
> http://lists.freebsd.org/pipermail/freebsd-ports-bugs/2010-March/184248.html

That patch is invalid.

The current code configures and builds properly with a recent mysql-cluster. 
It was developed originally against cluster 6.0.x. I have tested it again with 
the current MySQL Cluster 7.1.3 available here


> However, when building, I get the following error:

> This occurs with rebuilding the 2.4.19 SRPM, using the openldap.org 2.4.19
> tarball, and the openldap 2.4.21 tarball. I'm using the Redhat-supplied
> mysql-cluster.

Your MySQL package is obsolete by at least 2 years. This ITS will be closed. 
If you need more assistance talk to your distro vendor.

As a side note, if your distro vendor is unable to help you, supported RPMs of 
OpenLDAP with back-ndb are available from Symas Corp.
   -- Howard Chu
   CTO, Symas Corp.           http://www.symas.com
   Director, Highland Sun     http://highlandsun.com/hyc/
   Chief Architect, OpenLDAP  http://www.openldap.org/project/