[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#6302) second-guessing of libsasl ABI is incorrect for Linux distributions

hyc@symas.com writes:
> Though it goes against our usual desire to minimize distro-specific patch 
> maintenance, I think in this case I have to recommend that you continue to 
> carry this patch on your side.

Wrap such code in #ifdef on OPTIMISTIC_LIBVERSION_SASL or something in
OpenLDAP, so that people with 3rd party code done right can ./configure
CPPFLAGS=-DOPTIMISTIC_LIBVERSION_SASL instead of patching the code?