[Date Prev][Date Next] [Chronological] [Thread] [Top]

(ITS#6269) Fails to include inter-library dependencies on QNX

Full_Name: Matt Kraai
Version: 2.4.17
OS: QNX 6.4.1
URL: ftp://ftp.openldap.org/incoming/
Submission from: (NULL) (

When built on QNX 6.4.1, libldap.so doesn't include inter-library dependency
information.  When an application tries to link against it, it fails because the
symbols provided by the libraries that libldap.so should depend on aren't
defined.  Upgrading to a more recent version of libtool (e.g., 2.2.6) fixes this
problem, since it knows how to handle inter-library dependencies on QNX.  This
can be done by installing libtool 2.2.6 and running the following commands in
openldap's top-level source directory: