[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#5544) libRSAglue not found

steven@vaningelgem.be wrote:
> Full_Name: Steven Van Ingelgem
> Version: CVS
> OS: Ubuntu 8.04
> URL: ftp://ftp.openldap.org/incoming/
> Submission from: (NULL) (
> I compiled openssl 0.9.8g in static mode and put those files inside /myssl/lib
> or /myssl/include
> Now when I configure OpenLDAP with the following command:
> chmod +x configure build/version.sh&&  LDFLAGS="-L/myssl/lib"
> CPPFLAGS="-I/myssl/include" CFLAGS="-I/myssl/include" ./configure
> --disable-debug --disable-slapd --disable-backends --disable-local
> --disable-ipv6 --disable-syslog --enable-dynamic --enable-static
> --disable-shared --with-cyrus-sasl --with-tls=openssl
> It complains it cannot find openssl (due to it not being able to find
> "-lRSAglue")... I've been looking around for quite some time, but it seems not
> to exist (also not in some default packages in both Ubuntu and Debian).
> Also information for rsaref is sparse, but I could find it inside the openssl
> package as in "demos/engines"...
> This seems all very strange... Is there something I'm missing or is this really
> a bug in OpenLDAP?

Not an OpenLDAP bug. Specify the correct libraries in LIBS when running 
configure, like the INSTALL file says. This ITS will be closed.

   -- Howard Chu
   CTO, Symas Corp.           http://www.symas.com
   Director, Highland Sun     http://highlandsun.com/hyc/
   Chief Architect, OpenLDAP  http://www.openldap.org/project/