[Date Prev][Date Next] [Chronological] [Thread] [Top]

(ITS#5032) cannot build on x86_64, needs newer libtool

Full_Name: Hallvard B Furuseth
Version: RE23, HEAD
OS: RedHat Linux/x86_64
Submission from: (NULL) (
Submitted by: hallvard

libtool translates -ldb-4.3 to /usr/lib/libdb-4.3.so, which breaks.
"cc -ldb-4.3" uses /lib64/libdb-4.3.so.

Looks like the fix is to upgrade to libtool-1.5.24.  Its NEWS says
* Search paths with GCC on multilib systems like x86_64 have been fixed.

I haven't checked how to upgrade, though.  Tried to install a private
libtool and run libtoolize, but it just said "You should update
your `aclocal.m4' by running aclocal" even after I ran aclocal.