[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#4907) Syncrepl consumer failing to perform deletes

Sean Burford wrote:
> Hi,
> On 4/2/07, *Howard Chu* <hyc@symas.com <mailto:hyc@symas.com>> wrote:
>      > I am attempting to set up syncrepl between two OpenLDAP 2.3.32
>     servers.  Adds
>      > and Modifies are replicated from the provider to the consumer,
>     but deletes
>      > result in thousands of "unknown filter type 136644788" messages
>     in the consumer
>      > log and no deletion.  Commenting out the syncprov-sessionlog
>     directive works
>      > around the issue.
>     I don't see this with 2.3.32 on Linux 2.6.18. You'll probably need to
>     trace the activity with gdb to see what's wrong with the filter. 
> Right you are.  The patch for ITS#4638 (rejected here: 
> http://www.openldap.org/lists/openldap-bugs/200608/msg00043.html) 
> introduced the bug.  I'll send in a corrected patch once it has been QA'd.

The log says that ITS#4638 was already fixed in 2.3.32. Why are you 
still using that particular patch, given that an alternate solution is 
already present in the release?

I also see that in RE23 we had one more patch to fix some interaction 
between slapo-rwm and back-meta for filter processing. I suggest you 
test against the current RE23 code. I expect to push 2.3.35 out pretty soon.
   -- Howard Chu
   Chief Architect, Symas Corp.  http://www.symas.com
   Director, Highland Sun        http://highlandsun.com/hyc/
   Chief Architect, OpenLDAP     http://www.openldap.org/project/