[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: changing index sambaSID

I doubt this is due to a bug in OpenLDAP Software.  It is more
likely that the recommendation to have a substrings index is
inconsistent with the definition of the attribute type
(for instance, type may not support substrings matching).  But
regardless, you should consider updating to a modern version
of OpenLDAP.  2.2 is historic.

At 10:21 AM 7/18/2006, Anders Bonden wrote:
>I recently upgrade Samba to version 3.0.23. In the changelog it says that I must change slapd.conf to
>index sambaSID sub
>This worked on one of my ldap-servers, running SuSE 9.3, with openldap v. 2.2.15
>However, on the server running Debian Sarge with openldap v. 2.2.23-8 I get this error message when I run slapindex:
>/etc/ldap/slapd.conf: line 127: substr index of attribute "sambaSID" disallowed
>slapindex: bad configuration file!
>Does anybody know why and how to fix this?