[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#4577) Berkley db version incompatible - while installing open ldap 2.3

--On Saturday, June 03, 2006 10:19 AM +0000 priscilla@bheltry.co.in wrote:

> Full_Name: Priscilla Vincent
> Version: 2.3.20
> OS: Red Hat Linux 9
> URL: ftp://ftp.openldap.org/incoming/
> Submission from: (NULL) (
> I have installed Berkley DB version 4.2.52. After that i tried installing
> Open ldap by issuing the following command
> env CPPFLAGS="-I/usr/local/BerkeleyDB.4.2/include"
> LDFLAGS="-L/usr/local/BerkeleyDB.4.2/lib/" ./configure > config.log
> I get the below error and the installation quits after issuing the above
> command
> checking for Berkeley DB link (-ldb42)... no
> checking for Berkeley DB link (-ldb-42)... no
> checking for Berkeley DB link (-ldb-4.2)... yes
> checking for Berkeley DB version match... no
> configure: error: Berkeley DB version mismatch
> Kindly respond as soon as possible

This is not a bug.  I suggest you read the config.log file to find out why 
configure failed.  I also suggest you read the FAQ entry on linking against 


If you have further questions, I suggest you use the 
openldap-software@openldap.org discussion list.

I'll note that the current OpenLDAP release is 2.3.24, you'd probably be 
best served by upgrading your source as well.


Quanah Gibson-Mount
Principal Software Developer
ITS/Shared Application Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html