[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#4082) TLS broken in OPENLDAP_REL_ENG_2_3_10?

Pleaes try the latest OPENLDAP_REL_ENG_2_3.
Thanks, Kurt

At 12:24 PM 10/12/2005, kevins@bmrb.co.uk wrote:
>On Wed, 2005-10-12 at 18:04 +0100, Howard Chu wrote:
>> HEAD/RE23 works for me. Run ldapsearch with -d7 and/or slapd with -d7
>> and see what problems are encountered.
>A little more information.  I've tried various versions and find that
>the problem appears to be with ldapsearch rather than slapd.
>Attempting search against slapd from RE2.3 I find that the RE2.3
>ldapsearch -ZZ does not work but the one from 2.3.9 does.
>I have a hunch this is to do with openssl, mine was upgraded a few days
>ago (I'm running gentoo, so its probably fairly bleeding edge).  I've
>just recompiled all the 2.3 versions on my system (2.3.6 .7 .8 .9 RE2_3)
>and only 2_3 doesn't work.  So I suspect that if something has changed
>in openssl then something must also have changed in ldapsearch that is
>not compatible. 
>This message (and any attachment) is intended only for the 
>recipient and may contain confidential and/or privileged 
>material.  If you have received this in error, please contact the 
>sender and delete this message immediately.  Disclosure, copying 
>or other action taken in respect of this email or in 
>reliance on it is prohibited.  BMRB Limited accepts no liability 
>in relation to any personal emails, or content of any email which 
>does not directly relate to our business.