[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#4000) slapd (ppolicy) crashes on wrong password

There's not enough information here to identify the problem; at least a 
stack trace is needed. Also, a number of changes have been made to the 
ppolicy code since 2.3.4, you should update to 2.3.7 before re-testing.

yuvallb@netvision.net.il wrote:
> Full_Name: Yuv L
> Version: 2.3.4
> OS: RH ES3
> URL: ftp://ftp.openldap.org/incoming/
> Submission from: (NULL) (
> I'm using openldap with ppolicy.
> It was working well, and I was able to use it for different (light)
> application.
> Then I tested if qmail-ldap could use it.
> qmail uses its own dn (not manager) to read accounts information.
> at first I got a complaint from ppolicy about the entry missing some internal
> attributes, so I changed the password to something long.
> qmail continued using the same password, but now slapd crashed whenever it tried
> to bind.
> I get error:
> slapd: attr.c:207: attr_merge: Assertion `( nvals == ((void *)0) &&
> (*a)->a_nvals == (*a)->a_vals ) || ( nvals != ((void *)0) && (*a)->a_nvals !=
> (*a)->a_vals )' failed.

  -- Howard Chu
  Chief Architect, Symas Corp.  http://www.symas.com
  Director, Highland Sun        http://highlandsun.com/hyc
  OpenLDAP Core Team            http://www.openldap.org/project/