[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#3734) upgrade to 2.2 on a box with 2.1 installed causes new binaries to be linked against old libs

Followup for anybody else suffering from this issue.  After digging into it
some more (see gentoo link again http://bugs.gentoo.org/show_bug.cgi?id=93074)
I found that libldap was linking to the OLD liblber during building (see
readelf output).

On a hunch, I updated libtool in the package, using 'libtoolize --copy --force'
before running configure, and then the problem vanished entirely. Might I
suggest that upstream update the libtool (build/ltmain.sh) stuff that is used
in the distribution, as they are a LONG way out of date.

Robin Hugh Johnson
E-Mail     : robbat2@orbis-terrarum.net
Home Page  : http://www.orbis-terrarum.net/?l=people.robbat2
ICQ#       : 30269588 or 41961639
GnuPG FP   : 11AC BA4F 4778 E3F6 E4ED  F38E B27B 944E 3488 4E85