[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#3655) ppolicy update to draft 8

rhafer@suse.de wrote:

>Full_Name: Ralf Haferkamp
>Version: HEAD
>OS: -
>URL: ftp://ftp.openldap.org/incoming/rhafer-2005-04-12-ppolicy.dif
>Submission from: (NULL) (
>I found the following difference between draft-behera-ldap-password-policy-07
>and draft-behera-ldap-password-policy-08:
>- "pwdGraceLoginLimit" is now "pwdGraceAuthNLimit"
>- "pwdExpirationWarned" does no longer exist
>- Result codes for password update operations have been changed from
>  "unwillingToPerform" to "insufficientAccessRights"
The patch looks clean, I will commit it. However, we'll need some 
corresponding updates to the manpage, and we should probably replace -07 
with -08 in doc/drafts.

Also, I'm still not sure whether we need to worry about the Policy State 
Attribute options (draft 7 section 4.3.1, draft 8 section 5.3.1). I 
guess since we currently only support one password attribute 
(userPassword) it's probably not significant.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support