[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#3500) Changes to the directory do not show up imediately

rwmtch@rit.edu wrote:

>Full_Name: Bob Miller
>Version: OpenLDAP 2.2.20 Release
>OS: Solaris 9
>URL: ftp://ftp.openldap.org/incoming/
>Submission from: (NULL) (
>I have an intermittent issue where I will and an entry to the OpenLDAP directory
>with a call to ldap_add_s, get a successful return code, unbind from the
>directory and rebind, and search for the entry I just added.  Sometimes
>ldap_search_s returns entry not found even though later searches do find the
>entry.  The return from the commit and the folowing search all occur in the same
>second and the ldap server is often heavily loaded.  We have around 100000
>objects in our directory.  After a successful add any searches for the added
>entry should successfully return the entry as I have stated this is not
>currently the case.  This has happened atleast 9 times out of the last 311 times
>it could have happened in.  This was not an issue when we were running a version
>2.1 of the open ldap code.
What backend type are you using? There's not enough information in this 
report to begin any kind of analysis. At a guess, you're using 
back-ldbm. Showing us the database section of your slapd.conf may be 
helpful. Most likely switching to back-bdb will resolve the problem.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support