[Date Prev][Date Next] [Chronological] [Thread] [Top]

re: slapd crashes after successful search (ITS#3224)

I have solved this.

I use PAM for authentication with PADL pam_ldap. Running ldd on 
I found that it refers to libldap.so.2 and liblber.so.2.

Openldap 2.2.14 installation creates a symlink named libldap.so pointing 
to libldap-2.2.so.7 and a similar
symlink for liblber.so. No symlinks are created for these that end in .so.2.

My Openldap 2.1.30 had such symlinks, and this caused PAM to refer to 
the 2.1.30 libraries instead
of the 2.2.14 libs. Fixing the symlinks fixed the problem.

There was only one installed and referenced version of the sasl 
libraries, so this was not a factor.