[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: BIND 9 compile issue (ITS#2763)

> -----Original Message-----
> From: owner-openldap-bugs@OpenLDAP.org
> [mailto:owner-openldap-bugs@OpenLDAP.org]On Behalf Of
> jtownsend@apple.com

> Full_Name: Jason Townsend
> Version: OpenLDAP 2.2 (HEAD)
> OS: Mac OS X 10.3
> URL:
> http://homepage.mac.com/townsend/openldap-patches/libraries-li
> bldap.patch
> Submission from: (NULL) (
> There are some small changes necessary to compile with BIND
> 9, which is now the
> default on Mac OS X 10.3 (Panther). I have made a patch of
> the changes which
> allow things to compile on Mac OS X. This probably needs some
> modification to be
> workable across the various platforms OpenLDAP supports.
> The patch is available here:
> http://homepage.mac.com/townsend/openldap-patches/libraries-li

The makefile portion of this patch will not be accepted. Any additional
libraries like libresolv should be added to the LIBS environment variable
before running configure, as documented in the OpenLDAP "INSTALL" document.

The remainder of the patch needs to be #ifdef'd if it is going to break
compatibility with older versions of the resolver library.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support