[Date Prev][Date Next] [Chronological] [Thread] [Top]

ld: elf error: file ../../libraries/libldbm/libldbm.a: elf_getarsym (ITS#2726)

Full_Name: Raoul Becke
Version: 2.1.22
OS: Sun Solaris 8 2/02
URL: ftp://ftp.openldap.org/incoming/
Submission from: (NULL) (

Good morning everybody,
I have got the following configuration:
gcc -v: 
   gcc version 3.3
   Thread model: posix
   Configured with: ../configure --disable-nls --with-as=/usr/ccs/bin/as

Berkeley DB (www.sleepycat.com) installed: Version 4.1.25

I execute the following command (I tried almost every different configure switch
but this didn't help ether):

1. env CC=gcc CPPFLAGS=?-I/opt/BerkeleyDB/include?
LDFLAGS=?-L/opt/BerkeleyDB/lib? ./configure --prefix=/opt/OpenLDAP --enable-bdb
result: successful

2. make depend
result: successful

3. make
result: failed:
gcc -g -O2 -o slapd main.o daemon.o connection.o search.o filter.o add.o cr.o
attr.o entry.o config.o backend.o result.o operation.o dn.o compare.o modify.o
delete.o modrdn.o ch_malloc.o value.o ava.o bind.o unbind.o abandon.o
filterentry.o phonetic.o acl.o str2filter.o aclparse.o init.o user.o repl.o
lock.o controls.o extended.o kerberos.o passwd.o schema.o schema_check.o
schema_init.o schema_prep.o schemaparse.o ad.o at.o mr.o syntax.o oc.o
saslauthz.o oidm.o starttls.o index.o sets.o referral.o root_dse.o sasl.o
module.o mra.o mods.o limits.o backglue.o operational.o matchedValues.o cancel.o
version.o -pthreads  -L/opt/BerkeleyDB/lib libbackends.a
../../libraries/libavl/libavl.a ../../libraries/libldbm/libldbm.a
../../libraries/librewrite/librewrite.a ../../libraries/libldif/libldif.a
../../libraries/liblutil/liblutil.a ../../libraries/libldap_r/.libs/libldap_r.a
../../libraries/liblber/.libs/liblber.a /opt/BerkeleyDB/lib/libdb-4.1.a -lresolv
-lgen -lnsl -lsocket -ldl
ld: elf error: file ../../libraries/libldbm/libldbm.a: elf_getarsym
ld: fatal: File processing errors. No output written to slapd
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `slapd'
Current working directory
*** Error code 1

Any help is very appreciated
Thank you

PS: I already surfed the internet for hours and couldn't find an answer to this