[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: OpenLDAP configure/test error (ITS#975)

At 11:31 PM 1/19/01 +0000, stevecs@chaven.com wrote:
>Full_Name: Steve Costaras
>Version: 2.0.7
>OS: Linux v2.4.0 (Slackware deviant)
>URL: ftp://ftp.openldap.org/incoming/
>Submission from: (NULL) (
>My system:
># cat /proc/version
>Linux version 2.4.0 (root@ftp) (gcc version 2.95.2 19991024 (release)) #1 SMP
>Thu Jan 18 00:29:11 CST 2001
>Running Glibc v2.1.3, OpenSSL v0.96
>./configure doesn't seem to find openssl whether I point to to the installed
>location (/usr/local/ssl) or to the source location (../openssl-0.9.6).
>Output of configure is attached below.

The configure output shows configure did not find OpenSSL in the
default search path of your compiler.  If you want configure to
check elsewhere, specify appropriate environmental values as
noted in INSTALL and the Admin Guide.

As far as your other issue, I'd suspect your deviant software
selection is inconsistent.


www:/usr/src/openldap-2.0.7# ./configure --prefix=/usr/local
>checking whether the C compiler (cc   ) works... yes
>checking for openssl/ssl.h... no
>checking for ssl.h... no
>configure: warning: Could not locate TLS/SSL package
>configure: warning: TLS privacy protection not supported!