[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: devel build with BerkeleyDB 3.1 (ITS#649)

The patches I submitted didn't update configure itself.  So I had to run
autoconf, no big deal.  Should I have included a patch against
configure, or should people run autoconf?  I just want to get it right
in the future.

"Kurt D. Zeilenga" wrote:
> Fixed, please test, thanks.
>         Kurt
> At 01:28 AM 8/7/00 +0000, ian@nmsu.edu wrote:
> >Full_Name: Ian Logan
> >Version: devel
> >OS: freebsd
> >URL: ftp://acca.nmsu.edu/pub/ian/ian-logan-200806.tar
> >Submission from: (NULL) (
> >
> >
> >This set of patches allow devel to build with BerkeleyDB 3.1 (the API changed
> >again)
> >I've tested the patches on FreeBSD 4.1 with both bdb 3.0 and 3.1.
> >In both cases slapd passes all of its tests.
> >There are two patches inside the tar (build.patch and lib.patch)
> >build.patch fixes the HAVE_DB_THREAD test inside of configure,
> >and lib.patch fixes libldbm.
> >
> >The patches are against devel as of this afternoon.

Ian Logan
Computing & Networking
New Mexico State University
Email: ian@nmsu.edu Phone: 505-646-6034 Fax: 505-646-5278