[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: openldap on Linux/alpha (ITS#295)

On Fri, 17 Sep 1999, Kurt D. Zeilenga wrote:

> At 03:03 AM 9/18/99 GMT, jeffgus@zimage.com wrote:
> >> I believe this is caused by using an incompatible version of
> >> BerkeleyDB.  OpenLDAP requires BerkeleyDB 2.7.5 or later
> >> (available from http://www.sleepycat.com/).
> >> 
> >
> >	Hmmm.  I'll try it.  I'm using RH6.0 and OpenLDAP works fine on
> >the Intel version.  It's only when I tried to run it on the Alpha did I
> >have this problem.  I assumed the db versions would be the same since I'm
> >running RH6.0 on both Intel and Alpha.
> Or they might just fail in different ways...  If 2.7.5 (or later)
> should work.  If not, we'll have to dig a little.
> Kurt

	Okay I verified that RH6.0 uses the libdb that comes with glibc.
The version happens to be 2.4.14.  I didn't see anywhere in the FAQ on how
to get OpenLDAP to compile against a different version of DB on a glibc
system.  Any tricks?  Some sort of --with-db=/usr/local/BerkleyDB??