[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: help (ITS#108)

At 03:10 PM 3/23/99 GMT, jyzhou@nortelnetworks.com wrote:
>Now I try to compile OpenLDAP release 1.2 on HP unix.
>According to INSTALL instructions, when I type "make depend", 
>I got the following errors:

You C translator apparently doesn't use the -M option to generate
dependencies.   It may use -xM or something.  Check cc(1).  You
can then hack build/mkdep to use the appropriate option.

Or you can fetch the latest mkdep script from the CVS repository.
It supports the environment variable CC_MKDEP_FLAGS that can
be set to -xM or whatever.   ie:

env CC_MKDEP_FLAGS=-xM make depend