[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Deadlock (ITS#77)

Froze again!!

This time I managed to get some more info...

We were running slapd with errorlevel 4.  Now every time I attempt a
call to the server, it logs:

	ldap_pvt_thread_create failed (1)

If I attempt a "killall slapd", slapd logs:

	slapd shutting down - waiting for 10 threads to terminate

and just waits...  only way to kill it is with "kill -9"

I have gdb attached to slapd, but in my ignorance, I have no clue as to 
what to do next!

	any hints?


At 09:17 AM 2/18/99 , you wrote:
>Full_Name: Guillermo Payet
>Version: 1.2
>OS: Red Hat Linux 5.1
>Submission from: (NULL) (
>We've been running OpenLDAP 1.0.3 over dn 1.85 for a while, 
>with no major probelms.   Last Friday, I downloaded 1.2 and 
>DB 2.3.16.  After some initial trouble compiling the new 
>version (problems with config.cache), I got a system up and 
>Now slapd will run fine for a few hours, and then it will 
>deadlock.  I haven't been able to trigger the problem at will.  
>Sometimes it hangs, sometimes it doesn't, and it seems to 
>be independent of load.  Once it hangs I have to killall -9 
>I thought it might be a threading issue, but if I pound the 
>server hard with a few clients at the same time, it will run 
>fine, and then it will freeze a few hours later with only one 
>How should I approach this?  what loglevel should I use to 
>obtain a meaningful log file?
>    thanks
>    --Guillermo Payet

Guillermo Payet                         voice:       408.466.0700
O C E A N    G R O U P                  http://www.oceangroup.com