[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: error with "configure" (ITS#48)

Thank you! I solved it with your comments.

Kurt Zeilenga @[<:GT:

> Some versions of Solaris 2.x contains pthread functions which are
> not compatible with <pthread.h> and are not useable.  The autoconf
> system will detect this incompatibility but does not attempts to
> resolve it. configure will exit using out-of-the-box settings with
> the error:
>   checking if pthread_create() works... no
>   configure: error: pthread.h and pthread_create are not compatible
> To resolve this problem, the installer must specify the proper Pthreads
> libraries:
>   LIBS="-lpthread -lposix4"; export LIBS
>   ./configure --with-threads
> Note: the configure option '--without-threads' cannot be used on
> some versions of Solaris.
> See also:
>   http://www.openldap.org/faq/index.cgi?file=11
>   http://www.openldap.org/software/release/install.html

9i<.C6(Baek, Seok-chul)
at the Edge of Chaos..
Good luck to all with me..
Hand Phone: 016-235-1440
Office Phone: 561-4625