[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: -devel failed to compile on Sol 2.6

On Fri, Nov 20, 1998 at 08:06:09 +0100, Franky Van Liedekerke wrote:
> My system: Sun/sparc Solaris 2.6
> I downloaded the latest -devel version and after making a change to
> build/mkdep:
> CC=gcc (why isn't the variable AC_CC from the main Makfile used?)

I have seen this as well -- should be fixed ...

> gcc  -o slapd main.o daemon.o connection.o search.o filter.o add.o
> charray.o attr.o entry.o config.o backend.o result.o operation.o dn.o
> compare.o modify.o delete.o modrdn.o ch_malloc.o value.o ava.o bind.o
> unbind.o abandon.o filterentry.o phonetic.o acl.o str2filter.o
> aclparse.o init.o repl.o lock.o suffixalias.o schema.o schemaparse.o
> monitor.o configinfo.o version.o -L../../libraries -lldif -lldap -llber
> libbackends.a -lavl -lldbm  -lgdbm -llthread  -llutil
> -L/usr/local/gdbm/lib -lgdbm -lresolv -lgen -lnsl -lsocket
> Undefined                       first referenced
>  symbol                             in file
> sched_yield                         daemon.o
> ld: fatal: Symbol referencing errors. No output written to slapd

I have noticed this on my Sun box as well. My solution was to edit
the Makefiles: I added -lpthread to the list of link libraries.

On the cvs-version of openldap, I think that it tries to link with
-lposix4, which still is not sufficient to make a working slapd (even
if it links without diagnostics). Here I think that I added
-lpthread before -lposix4.

When linking with -lpthread, I can produce a working slapd.

Erik Bertelsen, UNI-C.