[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: [JunkMail] Re: LDAP_DEPRECATED in OPENLDAP_REL_ENG_2_2



> -----Original Message-----
> From: owner-openldap-devel@OpenLDAP.org
> [mailto:owner-openldap-devel@OpenLDAP.org]On Behalf Of Michael Stroder

> Still I also believe ldap_sasl_bind() is misnamed if it
> should be used for simple bind from now on.

Quibbling over this function name seems a bit pointless, unless someone here
is really going to put the energy into drafting a new API spec.

For my part, I would prefer that ldap_simple_bind and ldap_sasl_bind were not
segregated. E.g., something like

typedef struct LDAP_SASL_parms {
	LDAP_CONST char *mechs;
	unsigned flags;
	LDAP_SASL_INTERACT_PROC *interact;
	void *interactCtx;
} LDAP_SASL_parms;

ldap_bind(LDAP *ld, LDAP_CONST char *id, LDAP_CONST char *cred, int
authmethod,
	LDAPControl **sctrls, LDAPControl **cctrls, void *extra)

If authmethod == LDAP_AUTH_SASL then id/cred are SASL ID and password,
otherwise they are LDAP DN and password. "extra" is LDAP_SASL_parms * for a
SASL bind. etc...

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support